Brak Polskich znaków

Uwagi i sugestie na temat działania aplikacji Napisy24.
kapioyo
Posty: 1
Rejestracja: 22 gru 2016, 16:03

Brak Polskich znaków

Post autor: kapioyo » 22 gru 2016, 16:13

Witam, jestem nowym użytkownikiem programu napisy24 dlatego jeśli temat się powtarza proszę o link (wyszukiwarka mi nie pomogła :) )
Do sedna, kiedy pobieram napisy (dokładnie do House of Cards s01) są one bez Polskich znaków (tzn. zamiast ą,ę,ś mam 1,3,?). Pobrałem napisy bezpośrednio ze strony i wszystko było w porządku, oprócz dopasowania do filmu... W programie sprawdzałem już różne ustawienia (mam na myśli txt/srt i kodowania). Używałem odtwarzacza allplayer (napisy pobierane bezpośrednio z jego pomocą też miały ten defekt) VLC player naturalnie też je odtwarzał bez PL znaków... Jakiś pomysł co mogę zrobić? (windows 10. angielski, ale region i klaw. pozmieniane na PL)

Arczi
Administrator
Posty: 700
Rejestracja: 23 paź 2014, 18:37

Re: Brak Polskich znaków

Post autor: Arczi » 22 gru 2016, 16:49

czy jak program pobiera to masz jedną czy trzy gwiazdki przy tych pobranych napisach?

superzenon
Posty: 1
Rejestracja: 29 sty 2017, 21:05

Re: Brak Polskich znaków

Post autor: superzenon » 29 sty 2017, 21:12

Niestety problem wystepuje w angielskich wersjach windowsa. Ja mam 8.1, na drugim komputerze 7 i ten sam problem. Tak samo napiprojekt, co nie sciagniesz, nie wazne jaki format, kodowanie i tak nie bedzie polskich znakow. O dziwno nawet w ascii problem byl, nie wiem jak teraz, ale wczesniej tak bylo.

EDIT: @up, trzy giwazdki.

Jedyne rozwiazanie na szybko to (najlepiej) prosty edytor tekstu, ktory ma mozliwosc wyszukiwania wraz ze zamiana znakow, np. Notepad++.
Wpisujesz te znaczki i zamieniasz.

Myslalem, co by sobie napisac jakis skrypcik moze, ktory by te znaczki sam zamienial, ale jakos mi sie nie zebralo. :P

Poki co pozostaje niestety manualne pobieranie napisow.

A tutaj lista odpowiednich znaków:

Kod: Zaznacz cały

¹
ą

æ
ć

ê
ę

³
ł

ñ
ń

œ
ś

Ÿ
ź

¿
ż

¥
Ą

Ê
Ę

£
Ł

Œ
Ś

¯
Ż


Arczi
Administrator
Posty: 700
Rejestracja: 23 paź 2014, 18:37

Re: Brak Polskich znaków

Post autor: Arczi » 30 sty 2017, 11:44

napisy pobierane ze strony w formacie "SubRip (UTF-8)" na 100% powinny być poprawnie pokazywane w windows niezależnie w jakim jest on języku.
To samo w programie po ustawieniu kodowania j.w. - ale w programie to działa tylko dla napisów pobranych z 3 gwiazdkami.

HenryMycle
Posty: 1
Rejestracja: 06 mar 2019, 7:42
Lokalizacja: Sri Lanka
Kontakt:

Brak Polskich znakow

Post autor: HenryMycle » 13 mar 2019, 16:48

Problem pojawia sie rowniez w innych wiekszych modach. Pobralem spolszczenie, jednak to tez nie pomoglo, w przetlumaczonym tekscie dalej z polskich znakow figuruje tylko "o".

ODPOWIEDZ
meble kuchenne na wymiar warszawa